2.3. Patching the kernel

In addition to the base MD and Device Mapper support, EVMS requires a few patches for the EVMS engine to work correctly with these drivers. These patches are provided in the EVMS package, in the kernel/2.4.20/ subdirectory. See the INDEX files in the kernel/2.4.20 directory for descriptions of the patches.


If you are currently using the Sistina LVM2 tools, the patches provided here are not compatible with the LVM2 tools. EVMS has made some changes to the kernel ioctl packets so that they work correctly on ppc-64 and sparc-64 architectures. These changes have not yet been accepted by Sistina. Thus, for the time being, you need to use separate kernels for running EVMS and LVM2.

Apply each of the patches for 2.4.20 to your kernel as follows:

cd /usr/src/linux-2.4.20
patch -p1 < /src/src/evms-2.0.0/kernel/2.4.20/1-dm-base.patch
patch -p1 < /src/src/evms-2.0.0/kernel/2.4.20/2-syncio.patch
patch -p1 < /src/src/evms-2.0.0/kernel/2.4.20/3-dm-bbr.patch
patch -p1 < /src/src/evms-2.0.0/kernel/2.4.20/4-dm-sparse.patch
patch -p1 < /src/src/evms-2.0.0/kernel/2.4.20/5-md.c.patc
patch -p1 < /src/src/evms-2.0.0/kernel/2.4.20/6-vsprintf.c.patch
patch -p1 < /src/src/evms-2.0.0/kernel/2.4.20/7-vfs-lock.patch