2.6. Installing the cluster manager

Skip this section if you do not require high-availability features.

EVMS currently supports the Linux-HA cluster manager, commonly known as Heartbeat. You can download the latest version of the Linux-HA software from http://www.linux-ha.org/download/. EVMS works with Heartbeat V1.0.1 and later. For instructions on setting up a two-node cluster, see http://www.linux-ha.org/download/GettingStarted.html. For additional information and a list of frequently asked questions, see http://www.linux-ha.org/download/faqntips.html.

Linux-HA provides the following sub-packages:

"xxx" is the version of heartbeat; "arch" is the architecture of the target nodes.

You do not need to install heartbeat-ldirectord-xxx.arch.rpm because EVMS does not depend on its service.


The download page also contains tarballs and source rpms.

To install the package, execute the following command on each cluster node:

rpm -i heartbeat-pils-xxx.arch.rpm heartbeat-stonith-xxx.rpm \


It is highly recommended that you configure the STONITH package on a two-node cluster because data integrity on shared disks is at risk if STONITH is not configured. Although EVMS operates even when STONITH is not configured (EVMS is not restricted to a two-node cluster), EVMS's failover capability is limited by the support provided by the native cluster manager.

Refer to the STONITH device manual for instructions on how to configure the STONITH device.