6
A L T E R N A T I V E O F F I C E S O F T W A R E
KOffice
KOffice is an office suite still somewhat in its infancy, having
reached the 1.x release in 2001. Here we introduce KOffice's word
processing and spreadsheet applications, both of which are easy to use
and trustworthy. The KOffice suite includes many applications:

KWord: a frame- based, full-featured word processor and desktop-publishing
application.

KSpread: a standard, table- oriented spreadsheet application.

Kontour (formerly known as KIllustrator): a vector- based drawing program
along the lines of CorelDRAW or Adobe Illustrator. This application is
covered in Chapter 7.

KPresenter: a presentation application.

Kivio: a flowcharting application.
The following applications allow you to edit objects you want to insert, like
charts and graphics, into the main applications:

KChart: a chart- drawing program.

KFormula: a formula editor.

Krayon: a pixel- based, image manipulation program.
6594 LITW Chapter 6 9/12/02 7:42 PM Page 97
98
Chapter 6
Although many users opt to use OpenOffice's more mature environment,
we recommend following the development of KOffice, which may become a
standard in the near future.
You should be able to locate KOffice in your Linux distribution. If not, the
suite is available for download at http://www.koffice.org.
KOffice has an impressive lineup of office- related applications that function
acceptably well together, without taking up a lot of space on your hard drive.
You might notice that KOffice isn't as polished as other office suites, such as MS
Office and OpenOffice. However, you'll find that all of your bread-and- butter
functions, and more, are adequately covered.
T I P
Remember to visit KOffice's website frequently, http://www.koffice.org/, for new releases.
Navigating KOffice
Once KOffice is installed, launch it from the Office submenu of the K menu.
You can launch any of the individual applications from here, or you can type the
name of an application in the Run Command dialog box.
In addition to launching each application in KOffice separately, you have
the option of opening the KOffice Workspace (also from the Office submenu),
which opens the entire suite at once. On the left side are two useful menus:
Parts and Documents. You'll notice that the Parts menu conveniently allows you
to open any of the other applications. If you look toward the bottom you'll see a
button labeled Documents. Though it's out of the way and inconspicuous, this
menu allows you to switch back and forth between any open documents.
Certainly this navigation method is different from other standard office suites,
but you'll find it an efficient way to maneuver in KOffice.
Other than that, navigating KOffice is similar to navigating other office
suites. If you like using your mouse, you can click the menus and commands on
the top of the application bar. If you prefer the keyboard, you can use the same
types of keyboard shortcuts explained in the section of Chapter 5 called
"Keyboard Shortcuts in the OpenOffice Suite." For example, in KWord, press-
ing
ALT
-T and then S activates the Tools menu and launches the spell- checker
function. Unfortunately, it's impossible to move around between different files
within the KOffice Workspace without using the mouse.
Another helpful shortcut is the
CTRL
key and a letter to activate various
commands, which you can find in the menus on top. You may be familiar with
CTRL
-S for saving,
CTRL
-Q for quitting, and
CTRL
-P for printing, each of which
is standard in KOffice. Be careful, however, because now and then you'll come
across dead-end keystrokes, especially in text formatting. For example,
CTRL
-B
will create bold text on most word processors, but not in KOffice applications.
KWord
If you've ever experienced severe frustration trying to use a typical word proces-
sor for desktop-publishing (DTP), KWord may be the tool for you. KWord allows
you to position a series of one or more frames in a document, each containing
graphics, text, or objects from another KOffice application. The concept of
6594 LITW Chapter 6 9/12/02 7:42 PM Page 98
Alternative Office Software
99
frames was made popular by Adobe Framemaker software, and it enables
smooth integration of all elements.
One area where KWord needs improvement is file format portability.
KWord can import MS Word documents, but it cannot export them.
Furthermore, KWord will not open StarOffice or OpenOffice documents.
However, importing and exporting functions are in the works for AbiWord,
ApplixWord, DocBook, HTML, LaTeX, MIF, RTF, StarOffice, OpenOffice,
StarWriter, and WordPerfect.
Creating a New KWord Document
The most intuitive route to a new KWord document is clicking on the KWord
icon in the Parts menu. A dialog box comes up that asks you to select from
four options:

Create new document with template, which offers two options:
1.
Page layout documents: two templates with multiple frames are offered
for desktop publishing- oriented documents.
2.
Text- oriented documents: choose from A4, Plain Text, Two Columns or
US Letter templates for standard word-processing documents. Each
contains one major frame. (See "Using Frames" later in this chapter.)

Open an existing document.

Open a recent document.

Start with an empty document.
Figure 6.1: Opening a Document in KWord
6594 LITW Chapter 6 9/12/02 7:42 PM Page 99
100
Chapter 6
Once you've made your choice, you will have a new KWord document. Other
options for creating a new document include clicking the icon that looks like a
piece of paper in the upper left corner or choosing Open from the File menu.
Unfortunately for US users, the only template to offer margin measure-
ments in inches is the US Letter template. Otherwise, the measurements are in
millimeters, which offers a creative way to practice the metric system.
Furthermore, you will find a dearth of templates in KWord and KOffice in
general, meaning you'll have to create most types of documents on your own.
Opening an Existing Document
Select Open from the File menu to open an existing document. By default,
KWord will search first in your home directory, so this is a good place to store
your documents. Use the dialog box to find your file, then double- click the file,
or highlight it and choose Open.
Figure 6.2: A New Document
6594 LITW Chapter 6 9/12/02 7:42 PM Page 100
Alternative Office Software
101
If you get lost, you always can click the home (the usual house) icon to get
back to your home directory. Also, you'll be pleased to know about the com-
mand Open Recent, located below the Open command. Here you'll find a selec-
tion of documents that you've worked on recently.
Using Frames
If you open a text- oriented document, you essentially get one big frame. It func-
tions like a normal word processor if you only work with plain text.
For more complex documents, KWord uses a system of frames that makes it
much more powerful than a standard word processor. This function makes
KWord work more like a page layout program than a word processor. A frame is a
light gray box in the document. Frames allow you to lay out blocks of text, images,
and objects and place them wherever you like. To create a frame, select Text
Frame from the Insert menu. The mouse cursor will become crosshairs. Put the
crosshairs where you want one corner of the frame to begin. Left-click and drag
the mouse toward what will be the opposite corner, and an outline will be formed
representing your frame. When you reach the desired frame size, release the
mouse button. The Connect frame dialog box appears, asking if you would like to
create a frameset (a frame into which text from other framesets will not flow).
Figure 6.3: Opening an Existing Document
6594 LITW Chapter 6 9/12/02 7:42 PM Page 101
102
Chapter 6
To enter text, click inside the frame and start typing. If you want to move
the frame, place the mouse cursor along one edge of the frame until it becomes
a four-way arrow. When it does, left- click and drag the frame to the new loca-
tion. If you place the mouse cursor on one of the blue squares along the
perimeter of the square that appears when you left- click, you will get a double
arrow that allows you to stretch the boundaries of the frame to change the
length or height. To change the frame size in a way that is height-width propor-
tional, place the mouse cursor next to one of the blue squares in one of the
frame's corners.
Figure 6.4: Creating a Frame
Figure 6.5: Manipulating the Frame
6594 LITW Chapter 6 9/12/02 7:42 PM Page 102
Alternative Office Software
103
Formatting Your Document
Formatting allows you to choose character and page styles. Scores of options are
available in KWord. Advanced users can rest assured that other formatting fea-
tures, such as those to apply text styles, add tables, and create indexes, are all
available and generally located in the same places as they are in other word-pro-
cessing applications.
Choosing a Font
KWord's default font seems to vary with versions. To change the font, highlight
the text you want to modify and select a font type and size from the drop- down
Font menus above the document. The highlighted text will change accordingly.
Or simply set these options when starting a new document. Bold, italic, and
underline options are also available. Simply click the B, I, or U buttons, respec-
tively, to the right of the font toolbars. Superscript and subscript options are
also available on the Font menu or icons in the middle of the toolbar.
Figure 6.6: Formatting Your Document
6594 LITW Chapter 6 9/12/02 7:42 PM Page 103
104
Chapter 6
Aligning Text
KWord's default is to left-justify all text within a document. If you want some or
all of your document to be aligned differently, highlight the appropriate text.
Then select one of the alignment buttons in the bottom toolbar. Options
include left, centered, right, and forced justification. You can also determine
and set the alignment of your document before you begin typing.
Figure 6.7: Selecting a Font
Figure 6.8: Aligning Text
6594 LITW Chapter 6 9/12/02 7:42 PM Page 104
Alternative Office Software
105
Using Bulleted and Numbered Lists
Position your mouse pointer at the beginning of the paragraph or sentence
where you want to insert a bullet or number. Click the numbers icon on the bot-
tom toolbar. This icon will only give you a numbered list. (Click the icon again
to remove this feature and return to default formatting.) If you want to change
the numbers to bullets, choose Paragraph from the Format menu. In the dialog
box, select the Bullets/Numbers tab, which has options for altering the numera-
tion of the list or for changing the number to a bullet point.
Increasing and Decreasing Indents
To increase or decrease the indentation of text, click one of the two indent
icons, located to the right of the numbering/bullets icon. The icon with a left-
pointing arrow decreases the indentation, and the icon with text and a right-
pointing arrow increases the indentation. Click the appropriate icon more than
once to increase the indent in the same direction.
Applying Color
KWord allows you to add color to text characters, but you cannot highlight
blocks of text beyond the basic function of selecting. After selecting the text you
want to color, click the text color icon, the letter A over a colored box at the far
right in the bottom toolbar. A dialog box allows you to choose from a palette of
colors, or you can create your own color by clicking the color scale with the eye-
dropper tool and adding the color to the color palette.
Figure 6.9: Choosing the Type of Bullet to Add to Your Document
6594 LITW Chapter 6 9/12/02 7:42 PM Page 105
106
Chapter 6
Inserting Graphics into Your Document
Inserting an image into KWord is done differently than in other word proces-
sors. First, you need to select Picture Frame from the Insert menu, which will
bring up a dialog box showing the contents of your home directory.
Figure 6.10: Adding Color to Text Characters
Figure 6.11: Inserting a Graphic into Your Document
6594 LITW Chapter 6 9/12/02 7:42 PM Page 106
Alternative Office Software
107
Once you've found the image you want, click OK, and you'll get a crosshair-
shaped cursor. Use the cursor to draw a frame, or simply click, and your image
will appear in the frame. You can manipulate this in the same way as described
in the preceding "Using Frames" section.
KSpread
KSpread is a spreadsheet application featured in the KOffice suite. It has the
same look and feel as most spreadsheet programs. With KSpread you can per-
form basic spreadsheet functions, such as opening an existing, recent, or empty
document, and create formulas. However, this spreadsheet program is still in
development, and handy features such as templates are not yet available.
Creating a New Spreadsheet
To create a new spreadsheet, select KSpread from the Office submenu of the
K menu. The Choose Option dialog box opens, prompting you to open a new
spreadsheet or an existing one. Select Open New Spreadsheet, and a blank
spreadsheet will open.
Opening an Existing Spreadsheet
To open an existing spreadsheet in KSpread, select Open from the File menu,
or simply click the open icon to make the Open dialog box appear.
Figure 6.12: KSpread
6594 LITW Chapter 6 9/12/02 7:42 PM Page 107
108
Chapter 6
Moving around the Open document dialog box is quite intuitive. The up
arrow will take you back one directory level, the house icon will take you to your
home directory, and so on. When you have chosen the spreadsheet you want to
load, click its name and select OK.
Entering Data
Use the arrow keys to navigate between cells. Press
ENTER
to move down a cell.
Select a cell (with the arrow keys or the mouse) to enter information. You can
type either in the cell or in the form above the spreadsheet. The data appears in
both simultaneously, regardless of where you enter it.
To begin entering data into your spreadsheet, click in a cell and enter either
text or numeric data. Then click in another cell and continue building your
spreadsheet. This process is much like entering data into a word processor,
except each piece of data is entered one cell at a time.
Figure 6.13: KSpread Open Document Dialog Box
6594 LITW Chapter 6 9/12/02 7:42 PM Page 108
Alternative Office Software
109
When selecting a group of cells with the mouse, the last cell you highlight
will not actually be highlighted. It will, however, be outlined with a dark border
along with the other highlighted cells. The text styles, colors, fonts, and formats
can be changed either before entering data in the document or after the cells
have been highlighted. This is ideal if you want rows or columns to be differenti-
ated by color, font style, or size. To delete the contents of a cell, select the cell
and press the
BACKSPACE
or
DELETE
key.
Using Formulas and Functions
Formulas and functions perform calculations automatically before displaying the
results within a cell. For detailed information on entering formulas and func-
tions into a spreadsheet, refer to the "OpenOffice Calc: Spreadsheets" section in
Chapter 5.
In any cell where you want to create a formula or function, simply click in
the cell and begin with the standard
=sum()
entry, then add the formula or func-
tions. Then, list the headers of the row and column for which you want the cal-
culation performed (all within the parentheses).
T I P
A sum icon is featured in the KSpread top menubar. By highlighting the desired cells
and clicking the sum icon, you can automate your function process so that you don't
have to type in the equation manually. Additionally, a pull-down menu is featured to the
left of the sum icon and includes the word SUM. Click the pull-down menu, and other
automatic function options will become available to you.
Figure 6.14: Entering Data into Your Spreadsheet
6594 LITW Chapter 6 9/12/02 7:42 PM Page 109
110
Chapter 6
KWrite
KWrite is a simple text editor often favored by programmers because it features
colored syntax formattings customized for many programming languages. For
the standard office user, KWrite is an intuitive application that's ideal for times
when you want a quick and easy program in which to toss some text.
Figure 6.15: Entering Formulas and Functions in Your KSpread Spreadsheet
Figure 6.16: Opening a New File
6594 LITW Chapter 6 9/12/02 7:43 PM Page 110
Alternative Office Software
111
To launch KWrite, type
kwrite
into the Run Command dialog box. Or from
the K menu, select Editor and then Advanced Editor, which should open
KWrite automatically. Opening a new file is as easy as selecting New from the
File menu.
Writing, opening, or editing a document in KWrite are all standard tasks in
comparison to other text editors we have discussed. Familiar features such as
Undo, Cut, Copy, and Paste are all included.
AbiWord
AbiWord is a good word processor for people who need the basics and don't
like to wait for a heavy- duty office suite to start up. It's not part of KDE, and it
may not be included on your Linux distribution, but it's such a nice, lean, useful
little word processor that we wanted to include it here. If AbiWord is not
installed on your computer, you can find and download installation files at
http://www.abisource.com/. Although it looks pretty simple, AbiWord has a
powerful extension capability behind the scenes. You even can extend its capa-
bilities with scripts, if you care to learn a little bit of the Perl programming lan-
guage, and use the word processor as a front end for any Perl task you like.
AbiWord recently released version 1.0, which should be stable, but you
should always save your work frequently.
If you have used a word processor such as Microsoft Word or KWord, most
of AbiWord's features will be familiar, and online help is available. As with KDE
applications, AbiWord's Help menu invokes Konqueror to display help files.
Starting AbiWord
Start AbiWord from the Run Command dialog (
ALT
-F2 to bring up the Run
Command dialog box) by typing
abiword
.
From Your Browser or Mailer
AbiWord is an excellent choice for reading and printing word-processor files
that people send you as email attachments. You may want to make it your
default application for working with Microsoft Word documents (see the
"Opening Files" section of Chapter 3). AbiWord starts faster than other word
processors, so you can access your documents more quickly.
6594 LITW Chapter 6 9/12/02 7:43 PM Page 111
112
Chapter 6
Unlike some word processors, AbiWord does not have one main window with
multiple document windows inside. If you open multiple documents, you get
multiple real, top-level windows that can be moved to separate KDE workspaces.
You might have one instance of AbiWord with several documents open, span-
ning several desktops.
Working with Files
Besides its native format, AbiWord understands HTML 4.0, XHTML, Microsoft
Word format, RTF, DocBook, plain text, and other formats. The easiest way to
see the list of file formats currently supported is to select Save As from the File
menu and select the drop- down menu for Open File as Type. New formats are
added regularly.
T I P
To see your document in HTML format, choose Preview Web Page from the Web menu.
New, Open, and Open Copy
On the File menu, New and Open let you start working with a new document.
New creates a blank document, and both Open and Open Copy open an exist-
ing one. The difference between Open and Open Copy appears when you select
Save. If you have opened the document with Open Copy, the program will do
exactly that: open a copy of the file you selected. You will be prompted for a
new name for the document. This feature is helpful if you want to revise or
update a document but maintain the original, too.
The AbiWord Screen
Figure 6.17: AbiWord
6594 LITW Chapter 6 9/12/02 7:43 PM Page 112
Alternative Office Software
113
Save, Save As, and Save Copy
Save is dimmed if there are no unsaved changes, and you won't be prompted for
a filename unless you haven't yet named the document or if you opened it with
Open Copy.
Save As always opens a File dialog box and prompts you for a new name.
When you next save the file, AbiWord will save it under that name. Save Copy
opens a file dialog box and saves under the name you enter, but keeps the exist-
ing filename for the next Save operation.
New, Open, Save, and Save As are also available from the standard toolbar.
T I P
Make your work documents group-readable but not group-writable to allow your
coworkers to read your work and continue it under a new name without accidentally
overwriting it.
Setting View Options for Productivity
Nothing in the View menu actually changes any of the text in your document, so
it's a good place to start. Select Normal Layout to get rid of the gray areas
around the edges of your document, and select Zoom to Page Width to fit a
whole horizontal line on screen at once. Before printing, select Print Layout and
Zoom to Whole Page to preview.
Figure 6.18: The AbiWord File Menu
6594 LITW Chapter 6 9/12/02 7:43 PM Page 113
114
Chapter 6
T I P
Can't make up your mind if you want toolbars on or off? Use Full Screen (F11) to toggle
between a toolbar-heavy view and a sparse view with everything but the menubar
suppressed.

Formatting
AbiWord has basic formatting commands you may recognize from other word
processors. For example, you can select some text, click the little B on the for-
matting toolbar, and get bold text. Or, first click the little B and then type some-
thing--bold text, rejoice. Some formatting, such as font selection and bolding, is
applied character by character, and any changes you make will affect only the
currently selected characters or any new text you type. Other formatting, such as
text alignment and line spacing, is applied by paragraph. Changes affect the
paragraph where the cursor is, whether or not any text is highlighted.

You can get to the formatting commands in three ways: from the formatting
toolbar, from the Format menu, or by using the keyboard shortcuts, which are
listed in the Format menu. Select Undo from the Edit menu (

CTRL
-Z) to undo
any format command.
T I P
Single-spaced text in lines that span the entire page can be hard to read. Use the two-
column button on the Standard toolbar to break the text into two columns, or select double
spacing from the Extra toolbar, or select Paragraph from the Format pull-down menu.

Setting Tabs and Margins
The controls for setting tabs and margins are similar to those in other word
processors. Drag the two squares on top of the horizontal ruler to set the left
and right margins, and drag the top left triangle to set the indentation for the
first line of each paragraph.

To set tab stops, drag them to the horizontal ruler from the tab box, which
is to the left of the ruler. Tabs can be left, right, center, or decimal aligned. You
can drag tab stops along the ruler to move them, or drag them off the ruler to
clear them.

Set the top and bottom margins by using the vertical ruler. You can also set
the margins from Page Setup on the File menu, which is the one exception to
the rule that formatting items appear only on the Format menu.

Figure 6.19: The AbiWord View Menu
6594 LITW Chapter 6 9/12/02 7:43 PM Page 114
Alternative Office Software
115
Using Styles
By applying a style, you can specify all the formatting for selected text in one
step, instead of separately selecting the typeface, size, boldfacing, and margins.
This will add consistency to your documents.
To apply a style, either highlight text already present or set the style for text
you are about to type. Next, select a style from the Style combo box at the far
left of the Formatting toolbar, next to the Font menu. You can modify styles or
create new ones by selecting Style from the Format menu.
Using SpellChecker
AbiWord does spell checking on the fly by default. If you see a wiggly red line
below a word, right- click it to see a spelling menu. If one of the suggestions on
the spelling menu matches your intention, select it to change the word and get
rid of the red line. If you intended to type the word that way and want to add it
to the spelling dictionary, select Add.
Figure 6.20: Some Possible Styles in AbiWord
6594 LITW Chapter 6 9/12/02 7:43 PM Page 115
116
Chapter 6
To ignore a word in the current document only, without adding it to the
dictionary, select Ignore All.
You also can spell check the entire document by clicking the Spellcheck the
Document button on the standard toolbar, or by selecting Tools Check
Spelling Spelling.
T I P
To double-check a document, go to the Spelling tab of the Preferences dialog box and click
Reset to reset the list of ignored words.
Adding Links
You can make any selected text into a hyperlink that invokes Konqueror. If you
have the extra toolbar turned on (it can be activated by selecting Toolbars
View), click the little globe at the left once you've highlighted the word or words
that will be the link. If the toolbar is not displayed, select Hyperlink from the
Insert menu.
Setting Preferences
You can display a Preferences dialog box by selecting Preferences from the Tools
menu. Most of the options are self-explanatory; turn off features that you might
not want hogging your screen. Among other things, you can turn off the tool-
bars, rulers, and status bar individually, disable on-the-fly spell checking, and
suppress the initial AbiWord splash screen.
The Layout tab of the Preferences dialog box lets you turn on invisible lay-
out marks, including tab, space, and paragraph mark characters. This can be a
good choice if you want to make sure you're applying a style to only one para-
graph, or if you want to make sure you're not typing extra spaces by mistake.
Figure 6.21: Some Possible Styles in AbiWord
6594 LITW Chapter 6 9/12/02 7:43 PM Page 116