5
T H E O P E N O F F I C E S U I T E
This chapter gets you up and running with OpenOffice so
you can perform standard tasks such as building a spread-
sheet, making a chart, or writing and formatting a document. This
and the following chapter introduce you to tools well suited for the
office. While there are certainly more office applications available for
Linux, we cover only those sufficiently advanced in development to give you
confidence of use.
A vast array of office applications, both commercial and free, is available for
Linux. A group of applications presented in a similar fashion that comes bun-
dled together is often called a suite. The office suites that come with a price tag
include Anyware Desktop, previously known as Applixware Office (http://www.
vistasource.com); Corel's WordPerfect (http://www.wordperfect.com); and Sun
Microsystems' StarOffice (http://www.sun.com/software/star/staroffice/).
We feature some of those without a price tag in this and the following chap-
ter: OpenOffice, KOffice, KWrite, and AbiWord. StarOffice version 5.2 was for-
merly a free offering. With the release of version 6.0, Sun has begun charging a
moderate price for StarOffice (both versions) but has continued to offer
OpenOffice (http://www.openoffice.org) at no cost. It is included on many
Linux distributions, including SuSE. Keep in mind that a free product in the
Linux world does not translate into an inferior product. In fact, at SSC we have
used Sun's StarOffice as our default office suite for many years and are now
beginning to use OpenOffice.
6594 LITW Chapter 5 9/12/02 4:04 PM Page 71
72
Chapter 5
Most of the differences between OpenOffice and StarOffice can be
accounted for by the fact that StarOffice contains elements that Sun pays to
license, and therefore these elements are not included in OpenOffice. These
include certain fonts (such as Asian language fonts), database support, tem-
plates, and certain clip art images. StarOffice also offers manuals and support,
while OpenOffice does not. OpenOffice does, however, boast a rather compre-
hensive list of topics on the Help menu.
Those who rely on document templates will miss them in OpenOffice. This
is a feature that will probably be added to future versions, but if you can't do
without it, we recommend purchasing StarOffice, as it comes with a large vari-
ety of document templates.
Introduction to OpenOffice
OpenOffice is a feature- rich office productivity suite distributed and maintained
by Sun Microsystems. Comparable to Microsoft Office, OpenOffice includes a
word processor, a spreadsheet application, presentation software, and graphic
program applications. OpenOffice is incredibly powerful--many believe that not
only is it as good as MS Office, but also better in many ways. OpenOffice is
available for other platforms as well, including Solaris and Microsoft Windows,
and runs equally well on all of them.
OpenOffice offers the ability to import many different types of documents
and templates from a variety of other programs, including Microsoft Word. It
can also export to a wide range of formats, including HTML, PDF, and MS
Office XP.
Figure 5.1: OpenOffice Help
6594 LITW Chapter 5 9/12/02 4:04 PM Page 72
The OpenOffice Suite
73
OpenOffice may be included on your distribution already. If it is not, simply
visit http://www.openoffice.org. There you can download the latest version for
free. This site also contains a list of distributors who sell CD-ROMs that install
the software.
T I P
The users@openoffice.org mailing list is a great way to get help with OpenOffice. Visit
http://www.openoffice.org for details. Online help is also available.
The default OpenOffice installation places an OpenOffice submenu in the
K menu. From there, you can launch any of the OpenOffice programs (Writer,
Calc, Draw, or Impress). You can also click on any existing OpenOffice docu-
ment to open it within the appropriate OpenOffice application. Once the appli-
cation is open, another OpenOffice program can be started from the open
application's File menu.
The menus and toolbars may look familiar to you, as they are similar to
those of other office programs--the main menubar at the top and two tiers of
toolbars displayed by default. As usual, many of the most used menu items are
available from the icons in the toolbars. You can discover the function of an
icon by holding the mouse pointer over it.
T I P
If you find yourself using OpenOffice or any OpenOffice document often, add its icon to
the desktop or panel bar. See the "Adding Icons" section of Chapter 11 for details.
Figure 5.2: OpenOffice Writer
6594 LITW Chapter 5 9/12/02 4:04 PM Page 73
74
Chapter 5
Writer: Working with Text
Writer is a word processor that allows you to compose documents such as letters
and articles, as well as import and export documents from other systems in a
wide range of file formats that include HTML, ASCII, RTF, and MS Word.
Creating a New Document
When you launch Writer, you are put into a new document automatically, so
there is no need to do anything other than simply begin typing. If you'd like help
building your document, Writer provides a selection of AutoPilots for commonly
used documents such as fax cover pages, sales contracts, and school papers.
T I P
To set a style for your document, use the Paragraph Stylist. It is turned on automatically
when you launch Writer. Turn it on or off by selecting Stylist from the Format menu.
Using the AutoPilot
AutoPilot, often referred to as a wizard in other office programs, guides you
through a series of document customization questions.
To use this feature, select AutoPilot from the File menu. Then choose the
type of document you want to create. Options include memos, faxes, letters, and
web pages.
Once selected, the AutoPilot Agenda dialog box appears. You are instructed
to customize your document by choosing a layout style, including a logo or
graphic, and naming your file.
Click Next to select your desired options, and continue clicking Next each
time you are done with a set of customization questions. When you are finished,
click Create, and your document loads.
Figure 5.3: AutoPilot Agenda Dialog Box
6594 LITW Chapter 5 9/12/02 4:04 PM Page 74
The OpenOffice Suite
75
T I P
Turn on the Autotext feature on the Edit menu. Check the Display Remainder of Name
as Suggested While Typing box, and type the word you want to add to the Autotext list.

T I P
Count the number of words in your document by selecting File Properties Statistics.
Opening an Existing Document
To open an existing document, select Open from the File menu or click the open
file icon featured on the main OpenOffice toolbar (the icon is a file folder with a
little arrow indicating that it opens). It opens your home directory. Double-click
on the file you want to open, and your document loads automatically.

Figure 5.4: AutoPilot Agenda Document
Figure 5.5: Opening an Existing Document
6594 LITW Chapter 5 9/12/02 4:04 PM Page 75
76
Chapter 5
When you open a file from a directory in this way, the Open Folder dialog
box allows you to select a file type. OpenOffice defaults to All, which lists and
searches through all file formats automatically. You can choose to narrow the
number of formats by selecting a specific one from the File Type drop- down
menu. For example, if you have forgotten the name of the document you want
to open, but know it is in MS Word 97 format, select MS Word 97 from the
drop- down menu. Only the MS Word 97 files found within that directory are
then listed in the Open dialog box. For more file format options, see the Open
dialog box.
The Open dialog box also allows you to do things like create a new folder in
which to save or move documents; simply click the create new directory icon (it
pictures a file folder with an asterisk in the upper right corner). The default
directory icon, featured just to the right of the create new directory icon and
displaying a sledgehammer, allows you to return quickly to the default directory
(set by default as your home directory). To help navigate to the file you are look-
ing for, the up one level icon to the right of the create new directory icon takes
you the parent directory of the current directory. OpenOffice also lists the most
recently used documents at the bottom of the File menu for quicker access.
Importing and exporting MS Word and other documents created in popu-
lar word-processing file formats is quick and easy in OpenOffice. Follow the
example just given in "Opening an Existing Document" to import a foreign file
format. To save a document as a foreign file format, go to the Save As dialog
box, simply click the arrow within the File type text box, and select the desired
file format from the scroll bar.
T I P
OpenOffice comes loaded with a thesaurus. You can access it from the Tool menu.
Formatting Your Document
Formatting allows you to choose the font and page styles to apply to your docu-
ment. There are many options available in Writer. Here we review standard for-
matting tools. Advanced users can feel confident that other formatting features,
such as those that let you apply text styles, add tables, and create indices, are all
available. They are located generally in the same places you would find them in
other word processing applications. All of these formatting options can be set
before beginning a new document or applied to existing documents.
T I P
Spell check a document by selecting Spellcheck or AutoSpellcheck from the Tools menu.
T I P
When you begin a task or turn on a feature that OpenOffice thinks it can help explain,
such as AutoSpellcheck, a light bulb appears in the bottom left corner of the window.
Clicking on it brings up the relevant topic in the Help contents.
6594 LITW Chapter 5 9/12/02 4:04 PM Page 76
The OpenOffice Suite
77
Choosing a Font
The default Writer font is 12-point Thorndale. To change the font, simply high-
light the desired text and select the desired font type and size boxes just above
the document. Next to the font name and size are buttons for Bold, italic, and
underline.
Aligning Text
The Writer default is to left-justify all text within a document. If you want some or
all of your document to be aligned differently, highlight the appropriate text and
select an alignment icon (featured just above the document and next to the font
attribute icons). Options include left, centered, right, and forced justification.
Using Bulleted Lists
Place the mouse pointer at the beginning of the paragraph or sentence where
you want to insert a bullet or number. Click either the bullets or numbers icon
in the second row of icons at the top of the OpenOffice desktop. The para-
graph or sentence is instantly formatted as the appropriate type of list. To turn
off bulleting, move your mouse pointer to the beginning of the paragraph or
sentence where you want to end the list or delete a bullet, and again click the
bullets or numbers icon.
You can apply a different bullet or numbering symbol by selecting Numbering/
Bullets from the Format menu. The Numbering/Bullets dialog box appears.
Select the appropriate tab at the top (bullets, numbers, or graphics). Then click
the example box of your choice and click OK.
Figure 5.6: The Numbering/Bullets Dialog Box
6594 LITW Chapter 5 9/12/02 4:04 PM Page 77
78
Chapter 5
Increasing and Decreasing Indents
To increase or decrease the indentation of text, click one of the two indent
icons, featured just above the document to the right of the numbers and bullets
icons. The icon featuring text and an arrow pointing left decrease an indent,
whereas the icon featuring text and an arrow pointing right increase an indent.
Click the appropriate icon more than once to add more or less indentation.
Applying Color
Color can be applied to text characters or added as a highlight over a string of
text. The color icons are found next to the indentation icons. Select the text you
want to color or highlight by clicking and dragging your mouse pointer over the
desired text. Then click the icon featuring a yellow background behind the A
character, and your text is highlighted.
Color also can be applied to the background of a document. The icon that
features a complete palette of colors (positioned next to the character color
icons) performs this task for you. Click the background color icon. A dialog box
appears prompting you to select a color. Once you have clicked on the desired
color, your background changes to the new color.
Advanced Formatting Tools
Advanced page formatting tools are available in a central dialog box titled Page
Style. To access it, select Page from the Format menu, and the Page Style dialog
box appears.
Figure 5.7: Coloring the Background of a Document
6594 LITW Chapter 5 9/12/02 4:04 PM Page 78
The OpenOffice Suite
79
Here you are given the opportunity to select the background color, size, and
margins of the document; apply headers, footers, and borders; and even set
columns.
Advanced paragraph and character formatting tools are also available.
Select Paragraph or Character from the Format menu, and the Paragraph or
Character dialog box appears. From here you can apply drop caps, tabs, and
alignment, among other advanced paragraph formatting tools.
To add page numbers to your document, choose the Footer tab from
Format Page, check the Footer On box, and select OK. Next, from the Insert
menu choose Fields and then Page Numbers. A 1 appears in the footer. If you want
the page numbers to appear as "1 of 10" or "1 of 18", and so on, select Fields and
then Page Count. Next, under Footer, edit the text to add the word "of".
Figure 5.8: Page Style Dialog Box
Figure 5.9: Paragraph Dialog Box
6594 LITW Chapter 5 9/12/02 4:04 PM Page 79
80
Chapter 5
Inserting Graphics into Your Document
From the Insert menu, select Graphics and then From File. The Insert Graphics
dialog box appears.
Select the graphics filename just as you selected an existing document file.
Once your graphic appears in the document, you can double- click it at any time
to pull up the Graphics dialog box. Here you can crop, make the image a hyper-
link, or add a border. Once you have selected the options you want, click OK to
proceed with the changes or Cancel to cancel any changes.
Figure 5.10: Insert Graphics Dialog Box
T I P
You can move your graphic by simply clicking and dragging the image anywhere within
the document.
Figure 5.11: Graphics Dialog Box
6594 LITW Chapter 5 9/12/02 4:04 PM Page 80
The OpenOffice Suite
81
To delete the graphic, simply select it with the mouse and select the cut
icon, or right- click the image and select Cut from the pull- down menu.
Saving Your Document
To save your document, select the floppy disk (save) icon from the top toolbar
or select the Save or Save As options located on the File menu. The Save dialog
box appears, instructing you to name your file (if it is not already named), desig-
nate the directory to which you want to save the file, and choose the file format
you want your document to be saved as (click the arrow next to File type to see
a list of file format options). This is where you can prepare your document for
exporting, as mentioned previously.
T I P
To save your document as a PostScript file, select Print to File from the File Print
menu. Save the file with a .ps extension. Keep in mind that if you save a document in
this format, it cannot be re-edited, so you should save a copy in a standard document
format as well.
Creating Document Templates
Although the current version of OpenOffice does not come with existing docu-
ment templates, it is possible to create templates. Start by opening a new docu-
ment. Create a set of styles and give it the desired structure, and simply save the
document as a template from the Save As dialog box.
Figure 5.12: Inserting and Moving Your Graphic
6594 LITW Chapter 5 9/12/02 4:04 PM Page 81
82
Chapter 5
Printing Your Document
Printing your document is easy. Simply select the print icon from the toolbar
immediately below the menubar, or select Print from the File menu. In either
case, a Print dialog box opens, giving you the option to print to your printer or
to a file. Options are presented to print a range of pages, if you don't need the
whole document, or to print multiple copies.
T I P
You have more print options if you select Print from the File menu. The Printer toolbar
icon prints according to the defaults.
OpenOffice Calc: Spreadsheets
OpenOffice Calc is a powerful spreadsheet program that also imports and
exports other popular spreadsheet formats, including MS Excel. Spreadsheets
are large tables where information is entered in individual cells that appear in
rows and columns. They're ideal for accounting purposes and for creating data
comparisons.
Figure 5.13: Printer Dialog Box
Figure 5.14: OpenOffice Calc
6594 LITW Chapter 5 9/12/02 4:04 PM Page 82
The OpenOffice Suite
83
It is easy to enter data and formulas in OpenOffice Calc and to create
charts from that information.
To launch Openffice Calc, select Calc from the OpenOffice submenu in the
K menu.
T I P
For advanced users, OpenOffice Basic offers the opportunity to automate some of these
processes with macros. Select Macro from the Tools menu, or see the Basic IDE entry in
the OpenOffice Help.
Creating a New Spreadsheet
When you launch OpenOffice Calc, you are dropped into a new spreadsheet
automatically, and you can begin entering data. Or you can open an existing
spreadsheet (New Open) to begin working.
A spreadsheet contains cells organized in rows and columns. To begin
entering data into your spreadsheet, simply click in a cell. A black outline
appears around the selected cell. Enter data, either text or numbers. When you
are finished, simply click in another cell or press
ENTER
on the keyboard. You
can also use the arrow keys or the
TAB
key to move to the next cell. This process
is much like entering data into a word processor except that, in this case, each
piece of data is entered into one cell at a time.
T I P
To highlight a table area, click the upper left cell of the desired area and hold down the
mouse button. Then drag the mouse pointer to the bottom right cell and release.
Deleting or Moving Data
Since your spreadsheet is likely structured with formulas, deleting or moving
data can be a bit more complex than it is in a word processor.
To delete data in an individual cell, simply use the
BACKSPACE
key to delete
each character or number desired. To move data in one cell, right- click within
the cell. Select Cut or Copy, depending on which action you want. In the new
cell, right- click again, but this time select Paste.
Figure 5.15: Entering Data into Your Spreadsheet
6594 LITW Chapter 5 9/12/02 4:04 PM Page 83
84
Chapter 5
You also can delete or move all data contained in a row or cell. Use the
Delete Cells option on the Edit menu, or simply right- click on the data and
select Delete from the menu that pops up. This option allows you to specify
what should happen to the deleted row--for instance, move rows up or shift
columns.
Changing Heights and Widths
The cells in a spreadsheet are fairly small, but the size can be changed to accom-
modate larger entries and make data more readable on printouts. There are two
ways to accomplish size changes. The first is to place the mouse cursor over the
lines separating rows and columns in the guides (the lettered boxes at the top of
the spreadsheet for columns, and the numbered ones along the left side for
rows). For instance, if you want column A to be wider, position the mouse
pointer over the borderline between the column A guide and the column B
guide. When the pointer changes to a double-headed arrow, click and drag to
the left or right to shorten or lengthen the column as desired. For rows, it's the
same procedure except you move the double-headed arrow up and down to
shorten or heighten the rows.
A second way to change cell sizes is more precise, in that it allows you to
select measured increments. From the Format menu, select Cell, Row, or
Column. In the resulting submenu, choose the first entry (Column Width or
Row Height). Here you can enter a specific size in inches.
Using Formulas and Functions
Formulas and functions perform mathematical calculations automatically before
displaying numbers within a cell. A formula always begins with an equal sign (=)
and is created using alphanumeric combinations. Each cell has a grid address.
The cell in column A, row 1 is referred to as A1. The cell in column B, row 6 is
referred to as B6, and so on.
Formulas can be written to add, subtract, multiply, and divide. To write a
formula, start by typing an equal sign (=) within a cell. This tells Calc that you
want to perform a calculation. Then type the formula, for example, type
=A9+A10+A11+A12
. Press
ENTER
when the formula is complete. Calc performs the
calculations. In this case, it adds the numbers in the given cell and displays the
results in the cell in which you entered the formula.
Figure 5.16: Delete Cells Dialog Box
6594 LITW Chapter 5 9/12/02 4:04 PM Page 84
The OpenOffice Suite
85
A function is a predefined formula that performs calculations by using spe-
cific values in a certain order. A function begins with the function name, fol-
lowed by an opening parenthesis, the specific values (often referred to as the
argument) for the function, separated by a colon, and ending with a closing
parenthesis. Again, the function must be preceded by an equal sign. For exam-
ple, typing
=SUM(A9:A12)
into a cell and pressing
ENTER
yields the sum of the
values in A9 and A12 in that cell. Hundreds of functions are available in a vari-
ety of categories (logical, financial, and mathematical, for instance. Select
Function List from the Insert menu for a complete list of available functions.
Formatting Your Spreadsheet
Formatting a spreadsheet is much like formatting a document. The same capa-
bilities are available, such as features to alter fonts and font size, and add color
to some or all of the background. Refer to "Formatting Your Document" earlier
in this chapter for details.
When formatting a spreadsheet, you can easily format a single cell or an
entire group of cells. For instance, you may want to add a background color to
all cells in column D. To do so, highlight a group of cells by clicking the upper-
most cell of the desired area and holding down the mouse button. Then drag
the mouse pointer to the bottom cell and release. Now click the Background
Color icon, select your color of choice-- and voila!
T I P
You can make a row freeze so that it remains visible when you scroll down the window.
Click the bottom line of the last row you want to remain visible, and then select Freeze
from the Window menu.
Figure 5.17: Adding Color to a Column of Cells
6594 LITW Chapter 5 9/12/02 4:04 PM Page 85
86
Chapter 5
Making a Chart
It's easy to convert data from a spreadsheet into a chart. To begin, open an exist-
ing spreadsheet. Highlight the group of rows, columns, and headings from which
you want to build the chart. Select Object from the Insert menu, and then OLE
Object from the resulting submenu. The Insert OLE Object dialog box appears.
Select Create new, then Chart. Click OK. Your chart appears.
Figure 5.18: Insert OLE Object Dialog Box
You easily can change the size of a chart by clicking and pulling on the out-
lines of the box. To change text within the chart, click within the box on the
appropriate text. Right- clicking within the chart pops up many additional cus-
tomization options.
You can choose from many different types of charts. Double- click within
the chart, then select Chart Type from the Format menu. The Chart Type dia-
log box appears, prompting you to select one of several 2-D or 3 -D charts.
Figure 5.19: Creating Your Chart
6594 LITW Chapter 5 9/12/02 4:04 PM Page 86
The OpenOffice Suite
87
Saving Your Spreadsheet
To save your spreadsheet, use the same menu items as for saving a word-
processing document.
Select the Save or Save As options from the File menu. The Save dialog box
appears, once again instructing you to name your file (if it is not already named)
and choose the file format in which you want your spreadsheet saved (click the
arrow next to File type to see a list of file format options).
As with MS Word documents, you can import or export MS Excel and other
popular spreadsheet file formats in OpenOffice. Follow the example in the ear-
lier section "Opening an Existing Spreadsheet" to import a foreign file format.
To save a spreadsheet in a foreign file format, from the Save As dialog box sim-
ply click the arrow within the File Type box and select the desired file format.
Working with Multiple Pages in One Spreadsheet
Sometimes you may want to have multiple separate pages in one spreadsheet.
For example, say you create a detailed report every month. You want to have
every month on its own page, but you'd like to keep all the pages together.
Notice the tabs at the bottom of the screen that say Sheet 1, Sheet 2, and so on.
You can use your mouse to flip between the pages and rename them by right-
clicking a tab and choosing Rename. You can also change the order in which
the sheets appear by placing the mouse pointer on the tab, and then dragging
and dropping the sheet to the new location.
Printing Your Spreadsheet
Before printing your spreadsheet, you should take the time to think about how
you want your spreadsheet to look. Do you want the grid boxes to appear? Do
you want all of the spreadsheet or only certain data within it to appear?
Figure 5.20: Chart Type Dialog Box
6594 LITW Chapter 5 9/12/02 4:04 PM Page 87
88
Chapter 5
To print the entire spreadsheet, select Print from the File menu. To print
just a portion of your spreadsheet, highlight that portion, and then select Print
Ranges from the Format menu. From there, select Define. Now continue on
with the standard printing procedure.
It is common to turn off grid boxes on a spreadsheet before printing it.
Other formatting features include scaling the spreadsheet to fit on one page,
printing only a chart, and printing only the data. To access any of these format-
ting tools and others, select Page from the Format menu.
Often spreadsheets look better, and are more efficient and effective, if they
are printed across the page sideways to show more columns on a single printed
page. By default, all documents print in the normal 8
1
/
2
- inch by 11- inch layout,
called portrait mode. You can change the layout to landscape mode, which uses
an 11- inch by 8
1
/
2
- inch layout, by selecting Page from the Format menu. From
the resulting dialog box, choose the Page tab, and within the Page format sec-
tion, select Landscape.
OpenOffice Impress: Presentations and Slideshow
You can create presentations quickly and simply with Impress. The format for
information in a presentation is slides, which are a single screen in size and can
combine text and graphics. The presentation can then be printed or shown on
the monitor.
From the menubar, select File New Presentation. Select Empty presen-
tation from the AutoPilot Presentation dialog box, then click Next. On the fol-
lowing screens you are asked to make selections to customize your presentation.
The third screen allows you to add effects such as fades. After making your
selections, click Create.
Figure 5.21: The Calc Page Style Dialog Box
6594 LITW Chapter 5 9/12/02 4:04 PM Page 88
The OpenOffice Suite
89
At this point the Modify Slide dialog box appears, and you can choose the
layout of your slide. Make your selection and click OK.
The first slide of your presentation now appears. Click the area where you
want to feature text or insert a graphic. Begin typing (where there is existing
text, simply click the text and begin typing over it), or select Graphics from the
Insert menu and proceed by selecting the graphics filename of your choice.
Figure 5.22: Specifying a Layout
Figure 5.23: Adding Text to Your Slides
When you've completed the first slide of your presentation, you can insert
another slide by clicking the empty gray bar next to the tab of your first slide's
page at the bottom left side of the screen. To alter this newly created slide, sim-
ply right- click the new tab titled Slide 2 and select Modify Slide. You then con-
tinue as you did when creating your first slide.
6594 LITW Chapter 5 9/12/02 4:04 PM Page 89
90
Chapter 5
Fine-Tuning Your Presentation
To alter a slide, click the drawing view icon, which is located in the icon set
above the vertical scrollbar.
To change the sequence in which your slides appear, click the slide view
icon, located above the vertical scrollbar. From here you can easily drag and
drop slides into the sequence you desire.
Many other formatting options are available to you in OpenOffice Impress. In
fact, these are easily the topic for their own book. But truthfully, once you have
the basics, a little clicking around helps you discover what you need to know.
Saving and Exporting Your Presentation
You've finished the slides, and now it's time save your presentation. To do so,
select Save As from the File menu, name your presentation, and select Save.
Impress is the default file format, although you can save in a Draw or MS
PowerPoint format, if you prefer.
Exporting as a Web Presentation
Exporting your file as a web presentation is particularly handy, as it can then be
viewed by any web browser. Begin by selecting the Export option from the File
menu. Don't worry about which slide you are on when you do this. This action
exports the entire presentation.
Give your presentation a filename and save it. You are then guided through
the exporting process. First select an HTML design. Select New design from the
HTML Export dialog box, and click Next. You are instructed to choose a publi-
cation type. How do you want your HTML presentation to be displayed?
Options include plain HTML pages, frames, automatic slideshow view, or web-
cast. Select the desired customization options, and click Next. Depending on
which option you choose, you may be guided through the selection of a short
series of other HTML characteristics.
Figure 5.24: Exporting to HTML
6594 LITW Chapter 5 9/12/02 4:04 PM Page 90
The OpenOffice Suite
91
Once you've selected your HTML characteristics, you are ready to save your
HTML presentation. Select a file type (options include GIF or JPG), compres-
sion value, and screen resolution (the lower the resolution, the smaller the
graphic image files), and indicate whether you want a sound played when slides
advance. When you are finished, click Create.
Now you're ready to view your HTML presentation in a browser (or
OpenOffice). Simply open your web browser of choice and point your browser
at your HTML presentation's filename.
Printing Your Presentation
Printing your presentation (especially handy for overheads) is as simple as click-
ing the print icon at the top of the screen.
Viewing Your Presentation
To view your presentation as a slide show, click the start slide show icon above
the vertical scrollbar. Your presentation starts immediately and advances auto-
matically. You can select the time intervals, or you can choose to advance slides
with a mouse click, which is handy if you're doing a presentation with input
from other people.
To alter presentation settings, choose Slide Show from the menubar, and
then select Slide Show Settings.
A dialog box appears giving you the opportunity to change basic settings,
such as whether to include previously created slides or altering how the slides
change.
Figure 5.25: Accessing Slide Show Settings
6594 LITW Chapter 5 9/12/02 4:04 PM Page 91
92
Chapter 5
OpenOffice Draw for Graphics
OpenOffice features a graphics program called Draw. While it is technically a
vector program, it provides some of the bitmap functionality of programs such
as The GIMP and could be classified as a beginner- to intermediate-level graph-
ics program. It is well suited for combining text, shapes, lines, and images into a
single document, and has a limited ability to do a wide variety of tasks that usu-
ally require a specialized program. While some of its features are not as refined
as they are in programs such as The GIMP, the advantage is that they are com-
bined in one program. So if you want to create a business card with a graphic,
you can do it without moving back and forth between programs.
As with Kontour, Draw allows you to draw Bezier curves, geometric shapes,
and to import bitmap images into your document. You can also import spread-
sheets or charts from spreadsheets. With Draw, you can add 3-D shapes and con-
vert the boundaries of 2-D images to 3-D so they can be manipulated as 3-D
objects.
A Sample Draw Document
Let's say you're a used taxicab salesman and want to create an advertisement for
a community newsletter. You'll want some captivating text, an illustrative
graphic, and some data in the form of a graph demonstrating the superiority of
your product. You may even want some special effects for good measure.
Starting a new document in Draw is the same as with the other OpenOffice
programs (New Drawing).
Let's start with the text. Click the capital T icon in the left toolbar. This con-
verts the mouse pointer to crosshairs. This allows you to draw a text box where you
enter your text. Hold down the left mouse button to begin drawing the box, and
drag until the box reaches the desired dimensions (the outline appears as it is
drawn). Release the button when done. Then click inside the resulting box to begin
entering text. Remember that the features of OpenOffice Write are available to
you when working with text in Draw--such as spell checking and the thesaurus.
Figure 5.26: Entering Text
6594 LITW Chapter 5 9/12/02 4:04 PM Page 92
The OpenOffice Suite
93
To add a graphic, select Graphics from the Insert menu. This presents a dia-
log box allowing you to browse for the desired file. Like the text, the graphic
appears in a box with border points, and it can be manipulated by clicking and
dragging on the borders.
T I P
If you want to add an image from another document to the current one, you can right-click
on it and select Cut or Copy. Then right-click on the current document and select Paste.
To insert a chart, select Insert Object OLE Object. A dialog box
appears to allow you to choose the desired object. Select your chart, and it
appears in your document.
Figure 5.27: The Insert Graphics Dialog
Now you've got a document with text, a graphic, and a chart.
Figure 5.28: The Insert OLE Object Dialog
6594 LITW Chapter 5 9/12/02 4:04 PM Page 93
94
Chapter 5
To spice up your ad, you may want to add some kind of effect such as con-
verting your graphic to look like a charcoal sketch. Select the graphic by clicking
on it, making the Edit Points icon in the upper left corner of the Draw window
become a filter icon. Clicking on it reveals a number of options for modifying
the look of your graphic. These include solarization, mosaic, smoothing, relief,
charcoal sketch, and seven other options.
Figure 5.29: Sample Document with Text, Graphic, and Chart
To gain an appreciation of Draw's other features and an understanding of
working with graphics in general, it is recommended that you read Chapter 7,
"Working with Graphics," and Chapter 8, "More on Graphics: The GIMP." Then
you should be able to navigate through OpenOffice Draw's features fairly easily.
Figure 5.30: Turning Your Graphic into a Charcoal Sketch
6594 LITW Chapter 5 9/12/02 4:04 PM Page 94
The OpenOffice Suite
95
Keyboard Shortcuts in the OpenOffice Suite
Though moving around OpenOffice with the mouse pointer works very well,
you may want to speed things up a bit with keyboard shortcuts as you become
more proficient. Not moving your hand from the keyboard to the mouse can
save considerable time.
Two different kinds of shortcuts exist in OpenOffice. The first shortcut uses
the
ALT
key plus a letter to open a menu, and then a keystroke to select an
option within the menu. All shortcut letters are underlined in their menu list-
ings. For example, if you want to insert a horizontal line into a document, you
can press
ALT
-I to open the Insert menu, then press the Z key to open the
Insert Horizontal Line option box. Notice the underlined "z" in the word
Horizontal, indicating the keyboard letter to effect the shortcut.
The second type of shortcut is called an accelerator. Using the
CTRL
key with
a keystroke, you can execute a task instantly, such as saving a file or printing a
document. Accelerator shortcuts are documented in the menus to the right of
the listed items. For example, assume that you're in a document and want to
print it. Rather than using the mouse to select File and then Print, you can
press
CTRL
-P to open the Print dialog box. Spend some time looking through
the menus and experimenting with the many available shortcuts.
After you've spent some time working with the OpenOffice suite and learn-
ing the shortcuts for the functions you use most, you'll come to appreciate its
power, features, and flexibility, and wonder how it is free of charge.
Figure 5.31: As shown in the menu, the Accelerator to open a file is
CTRL
-O
6594 LITW Chapter 5 9/12/02 4:04 PM Page 95
6594 LITW Chapter 5 9/12/02 4:04 PM Page 96